Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2026 - 14:00 UTC
Scheduled
We will be undergoing scheduled maintenance tomorrow, 1 July, from 1400 to 1600 UTC on the test admin tool - test.crossref.org. Our members may experience delays in test admin tool (test.crossref.org) processing. Test deposits submitted during this time will be stored and processed after the maintenance has been completed. -IF
Posted Jun 30, 2026 - 17:58 UTC
This scheduled maintenance affected: Content Registration (Test admin tool).