Problems with load on the Event Data service.
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted May 24, 2019 - 18:38 UTC
Investigating
We’re currently experiencing problems with load on the Event Data service. Users may see their queries time out. We’re investigating and will confirm when the issue is solved
Posted May 13, 2019 - 12:28 UTC
This incident affected: APIs (Event Data Query API).