Deposit processing delays
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Jan 05, 2019 - 23:37 UTC
Investigating
We're investigating an incident with our deposit processing (doi.crossref.org) infrastructure. No deposits have been lost and we're still accepting and storing your submissions, but processing is currently delayed.

If you have any questions, contact the support team at support@crossref.org.
Posted Jan 05, 2019 - 23:11 UTC
This incident affected: Content Registration (Admin tool).