Investigating a problem with the deposit system - doi.crossref.org
Incident Report for Crossref
Resolved
We had a configuration problem with our deposit system, which we have fixed. The problem resulted in a few deposits processing more slowly than usual.
Posted Apr 11, 2019 - 13:54 UTC
Investigating
We are currently investigating a problem with the deposit system. Members may continue to submit deposits, but there will be a delay in processing while we determine the cause.
Posted Apr 11, 2019 - 13:18 UTC
This incident affected: Content Registration (Admin tool) and Beta (Metadata Manager).