Cursor requests not returning all results in the REST API

Incident Report for Crossref

Resolved

This incident has been resolved and our REST API is operating normally.
Posted Jul 06, 2026 - 10:06 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 03, 2026 - 14:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 03, 2026 - 13:27 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 02, 2026 - 19:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 17:54 UTC

Update

We are continuing to investigate this issue.
Posted Jul 02, 2026 - 15:57 UTC

Investigating

We have received multiple reports that requests in the REST API that use cursors to paginate through multiple pages of results are finishing early and not returning all of the requested records. We are  investigating the cause. -IF
Posted Jul 02, 2026 - 13:00 UTC
This incident affected: APIs (Public REST API, Polite REST API), Metadata Plus (Plus REST API), and Sites (Metadata search).