Error message logging into our web deposit form
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 18:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 26, 2021 - 14:00 UTC
Investigating
Members are reporting seeing the error message "An error occurred, please try again" when logging into the web deposit form. We're looking into the problem and will let you know as soon as we know more.
Posted Apr 26, 2021 - 06:25 UTC