Submission log emails not being sent for all registrations

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 03:27 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 28, 2025 - 16:06 UTC

Update

We are continuing to investigate this issue.
Posted Oct 27, 2025 - 21:04 UTC

Investigating

We have found that starting on 24th October around 1800 UTC that not all submissions logs are being emailed to our members. Our technical team is investigating. -IF
Posted Oct 27, 2025 - 18:10 UTC
This incident affected: Content Registration (Admin tool).