All DOI resolutions failed between 00:30 and 01:30 UTC
Incident Report for Crossref
Resolved
This issue has been resolved.

doi.org has shared the details on their status page: https://doi.statuspage.io/incidents/f4hrmd88c94l, which are also included below:

'The issue seems to be caused by some failure of Cloudflare's "Load Balancing" product which is used by doi.org to steer global traffic to appropriate backend servers. We have worked around this issue in order to restore doi.org resolution services, but were not immediately able to restore full geo-steering functionality or determine why the failure happened. We will add information as it becomes available.

By roughly 03:30 UTC we restored geo-steering by routing through AWS's "Global Accelerator" product. We are still working with Cloudflare to determine the source of the issue.' -IF
Posted May 29, 2024 - 19:51 UTC
Update
We can now follow the details on the DOI Foundation status site: https://doi.statuspage.io/incidents/f4hrmd88c94l. A workaround has been implemented but there is ongoing work to optimise Cloudflare and determine the cause.

-GH
Posted May 29, 2024 - 09:25 UTC
Monitoring
We understand from CNRI that this was due to a cloudflare issue and that it is now fixed. We’re monitoring and hope to link to more details soon. -GH
Posted May 29, 2024 - 06:29 UTC
This incident affected: External dependencies (Handle servers).