Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2023 - 11:00 UTC
Scheduled
We will be releasing an update to Crossref Metadata Search (https://search.crossref.org/) during this time. We hope that users will not have any interruption to their service, but there may be disruption to service during this hour.
Posted Sep 22, 2023 - 10:45 UTC
This scheduled maintenance affected: Sites (Metadata search).