Degraded performance on Public and Polite REST API

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 09:43 UTC

Update

We are continuing to monitor our fixes for any further issues affecting the Public and Private REST APIs, Crossmark, content negotiation, and metadata search.
Posted Jun 23, 2026 - 16:24 UTC

Update

We experienced a couple of downtimes for the Public REST API at 3:09 and 4:15 UTC due to high rates of requests. We are continuing to implement fixes and are monitoring the degraded performance on the Public and REST APIs.
Posted Jun 23, 2026 - 09:01 UTC

Monitoring

We have deployed and are monitoring a fix for this issue that affected our APIs and Metadata Search.
Posted Jun 22, 2026 - 11:39 UTC

Update

We are continuing to work on a fix for the performance issue.
Posted Jun 22, 2026 - 11:22 UTC

Identified

We are receiving a very large number of requests from a user that is applying various strategies to get around our rate limits on our public REST API pool. This is impacting performance, including on the public and polite REST API pools, Crossmark, content negotiation, Crossref Metadata Search and reference matching. We are investigating solutions.
Posted Jun 22, 2026 - 10:20 UTC
This incident affected: APIs (Public REST API, Polite REST API, Crossmark dialog server, Public content negotiation, Polite content negotiation) and Sites (Metadata search).