Crossref DOIs not resolving/ DOI registration failing

Incident Report for Crossref

Resolved

This incident has been resolved. All affected metadata submissions have now been reprocessed.
Posted Mar 17, 2026 - 20:03 UTC

Monitoring

We continue to monitor the system to ensure stability and consistent processing of registrations.
Posted Mar 17, 2026 - 10:38 UTC

Identified

The DOI Foundation identified the issue as a surge in traffic affecting the backend infrastructure of doi.org. This has been resolved. Crossref registration servers have been restarted, and metadata registrations are now processing successfully.
Posted Mar 17, 2026 - 10:35 UTC

Update

UPDATE: Crossref DOIs have not been resolving as expected since around 06:56 UTC. Any attempt to resolve them returns the error message: “DOI Cannot Connect to Server.” Some DOI registrations are impacted too. We are closely working with the DOI Foundation on a fix.
Posted Mar 17, 2026 - 09:45 UTC

Investigating

Crossref DOIs have not been resolving as expected since around 06:56 UTC. Any attempt to resolve them returns the error message: “DOI Cannot Connect to Server.” We are currently investigating the issue.
Posted Mar 17, 2026 - 07:56 UTC