Continued Problems with load on the Event Data service.
Incident Report for Crossref
Resolved
The heavy load on the Event Data API has been resolved for now.
Posted Nov 19, 2020 - 10:54 UTC
Investigating
We’re still experiencing problems with load on the Event Data service. Users may see their queries time out when using the API. We’re investigating and will confirm when the issue is resolved.
Posted Jul 04, 2019 - 13:15 UTC
This incident affected: APIs (Event Data Query API).