Degraded performance in our test admin tool - test.crossref.org

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 22:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2025 - 20:29 UTC

Investigating

Our test admin tool - test.crossref.org - is experiencing degraded performance at the moment. Author-title and funder searches for deposits are failing and we have a backlog of test submissions that we're working through. Our technical and infrastructure teams are investigating. -IF
Posted Dec 16, 2025 - 19:11 UTC
This incident affected: Content Registration (Test admin tool).