Cloudflare network problems affecting DOI.org resolution

Incident Report for Crossref

Postmortem

CNRI has written a postmorterm about how they handled the Cloudflare outage for doi.org: https://doi.statuspage.io/incidents/z0rwt8tqcfsm

Posted Nov 20, 2025 - 20:23 UTC

Resolved

Clouflare reports that the issues are fixed, and DOIF subsequently reports that doi.org resolutions have returned to normal.
Posted Nov 18, 2025 - 20:01 UTC

Update

The DOI Foundation is also aware: https://doi.statuspage.io/incidents/z0rwt8tqcfsm
Posted Nov 18, 2025 - 13:12 UTC

Investigating

Cloudflare network problems are affecting multiple sites, including doi.org resolution, meaning many DOI links are very slow or result in errors. https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:51 UTC
This incident affected: Integrations and external dependencies (Handle servers).