Metadata Plus REST API performance lags

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 15:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 18, 2025 - 20:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 18, 2025 - 16:28 UTC

Identified

We’ve had several reports of performance lags of the Plus pool of our REST API from Metadata Plus users. We have identified the source of the degraded performance and are working on a fix. It could be 24 to 48 hours before we have that fix in place.
Posted Jun 18, 2025 - 13:25 UTC
This incident affected: Metadata Plus (Plus REST API).