Submission logs not being emailed for registrations to our admin tool - doi.crossref.org
Incident Report for Crossref
Resolved
Many of the emails containing submission logs for our members' registrations bounced yesterday and early today. We have resolved the immediate crisis and email notifications are again being sent and delivered.

Unfortunately, we don't have a mechanism for resending those bounced emails. Members who have been awaiting emails containing their submission logs for registrations made yesterday or today should access our admin tool to review those submission logs using these instructions: https://www.crossref.org/documentation/register-maintain-records/verify-your-registration/submission-queue-and-log/#00143
Posted May 16, 2023 - 16:12 UTC
Investigating
We have had several members report that they are not receiving submission logs via email for their registrations. We have been able to replicate the issue and are investigating it further. In the interim, we are still processing those submissions and you can confirm any past registrations in our admin tool using these instructions: https://www.crossref.org/documentation/register-maintain-records/verify-your-registration/submission-queue-and-log/#00143
Posted May 16, 2023 - 14:30 UTC
This incident affected: Content Registration (Admin tool).