Processing of deposit submissions (content registration) delayed
Incident Report for Crossref
Resolved
We've fixed the problem, and made significant progress in reducing the number of pending submissions in the admin tool deposit queue. This incident has been resolved.
Posted Jan 15, 2021 - 19:09 UTC
Monitoring
A fix has been implemented and we're monitoring it. We're processing your deposit submissions as fast as we can - running additional threads to catch up - but there is still a consider backlog of submissions to work through.
Posted Jan 12, 2021 - 19:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 12, 2021 - 18:44 UTC
Update
We'll use the regularly scheduled maintenance window tomorrow, Tuesday, 12 January, at 1600 UTC, to further investigate the underlying issues with query timeout errors and sluggish deposit processing.
As a reminder, deposit processing capacity using all of our submission methods (admin tool: doi.crossref.org; HTTPS POST, OJS, web deposit form, Metadata Manager) is at 75 to 80% of what it normally is. Deposit submission processing remains delayed.
Posted Jan 11, 2021 - 18:44 UTC
Update
We have found that the problems with deposit processing in our admin tool are related to query timeout errors, which will take more time for us to fix. In order to reduce potential problems over the weekend, we have reduced processing capacity by 20%. Thus, members will likely experience delays in submission processing through Monday, 11 January. We'll provide updates on Monday, 11 January.
Posted Jan 08, 2021 - 21:05 UTC
Investigating
Processing of deposit submissions using all of our submission methods (admin tool: doi.crossref.org; HTTPS POST, OJS, web deposit form, Metadata Manager) are currently delayed. We're investigating and hope to get back to registering your content ASAP.
Posted Jan 08, 2021 - 20:38 UTC
This incident affected: Content Registration (Admin tool) and Beta (Metadata Manager).