Submission processing delays today
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted May 01, 2024 - 20:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2024 - 18:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2024 - 16:13 UTC
Investigating
We've had several members notify us that submission processing (from XML submissions via HTTPS POST) has been delayed today. We're aware of the situation and believe we have identified the cause of the problem. We're working on catching up on the backlog of submissions now. -IF
Posted May 01, 2024 - 14:37 UTC
This incident affected: Content Registration (Admin tool).