query.title feature blocked on REST API
Incident Report for Crossref
Resolved
We've been monitoring for 16 hours, and it looks as though the work we've done to block the query.title feature on the REST API has made the REST API and dependent services stable.
Posted Oct 17, 2019 - 11:23 UTC
Monitoring
We've now put the block in place on the query.title feature of our REST API.

If you’re currently using query.title, please change to query.bibliographic instead.
Posted Oct 16, 2019 - 18:47 UTC
Identified
Important: query.title feature to be blocked on REST API

As users will have noticed, we’ve been having recurring performance issues on the REST API and related services such as Crossref Metadata Search and Content Negotiation. This has been particularly problematic over the last couple of days.

We’ve identified that this is due to the query.title feature on the REST API. Because of the way it's implemented, it seems to be degrading the performance of the REST API on all pools in which it’s used (public, polite and plus). The impact is not only on queries that use query.title but on all other users of the system too.

Because this is causing serious issues for dependent services, we’re planning on taking the step of blocking all use of the query.title feature later today. We’ve tried other fixes as an alternative, but this is the approach that will benefit the greatest number of users who are being affected by the performance issues. We’re aware that this is very short notice, but it’s the one way for us to stabilise the service for all users - the small group using query.title, and all other users too.

If you’re currently using query.title, please change to query.bibliographic instead. This is designed for title matching, so should in fact be a better fit for you.

We will update you when we introduce this change. At this point, anyone using the deprecated query parameter will see an HTTP 400 status code and an explanation.
Posted Oct 16, 2019 - 17:29 UTC
This incident affected: APIs (Public REST API, Polite REST API, Public content negotiation), Metadata Plus (Plus REST API), and Sites (Metadata search).