This incident has been resolved. Members can now log in to our test admin tool - test.crossref.org - as normal. Between approximately 21:30 UTC on 20 September and 08:30 UTC on 21 September, members attempting to log in saw the error "Error connecting to the authentication service." Our technical team restored the service and confirmed that login is working again.
Posted Sep 21, 2026 - 09:18 UTC
Investigating
Members attempting to access the test admin tool - test.crossref.org - are experiencing the following error: 'Error connecting to the authentication service. Please try again later or contact support.' Our technical team is investigating the issue.
Posted Sep 21, 2026 - 02:57 UTC
This incident affected: Content Registration (Test admin tool).