Crossref admin tool is currently down

Incident Report for Crossref

Resolved

The admin tool is available once more. The team are investigating the reasons for the outage.
Posted May 29, 2025 - 11:11 UTC

Investigating

The Crossref admin tool has been down for the last 10 minutes. Our team is aware and are investigating. More as we know it.
Posted May 29, 2025 - 10:56 UTC
This incident affected: Content Registration (Admin tool).