www.crossref.org was down for 70 mins on Sunday, 13 September; we're monitoring for the coming weeks

Incident Report for Crossref

Update

We have deployed a fix for this issue and are monitoring the results. -IF
Posted Sep 15, 2026 - 17:01 UTC

Monitoring

Yesterday, 13 September, we reported an incident with our website: www.crossref.org. It was down from 11:13 to 12:23 UTC. We resolved that incident prematurely. The outage was caused by a know intermittent issue that our technical team is working to resolve, but does not yet have fixed. We're monitoring the issue, and anticipate doing so for the foreseeable future. Thus, we have re-opened a new incident here. We'll provide updates as we have them. -IF
Posted Sep 14, 2026 - 23:19 UTC
This incident affects: Sites (Crossref website).