Depositor reports returning gateway timeout errors

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 18:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2026 - 18:35 UTC

Investigating

Our depositor reports (e.g., https://data.crossref.org/depositorreport?pubid=J533343) are returning status code 504 gateway timeout errors. We're aware of the issue and our technical team is investigating. -IF
Posted Apr 03, 2026 - 18:31 UTC