REST API Plus pool has a slow response rate

Incident Report for Crossref

Resolved

We have made changes on our end that has resulted in better response times. This incident has been resolved. -IF
Posted Aug 08, 2025 - 15:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 07, 2025 - 15:15 UTC

Monitoring

Things have settled down as a result of our changes and the Plus pool is performing better now. We're monitoring.
-GH
Posted Aug 06, 2025 - 10:35 UTC

Investigating

Metadata Plus subscribers may be experiencing slow responses or timeouts from the REST API. We're still completing the setup of rate limiting in the new cloud environment, so we are focusing on getting that done ASAP.
-GH
Posted Aug 05, 2025 - 09:07 UTC
This incident affected: Metadata Plus (Plus REST API).