Delivery of July's resolution reports delayed

Incident Report for Crossref

Resolved

This should all be resolved now and the reports should not be resolving to a 404 error anymore.
Posted Jul 25, 2025 - 09:01 UTC

Update

All of this month's resolution reports have now been delivered. The links within the reports continue to resolve to 404 'page not found' status code errors. We expect to have those links repaired tomorrow. -IF
Posted Jul 25, 2025 - 00:50 UTC

Update

Several members have reported that the links within the resolution reports are returning 404 'page not found' status code errors. We are actively working to fix those links and hope to have those routed properly within the next 24 hours. -IF
Posted Jul 24, 2025 - 12:35 UTC

Update

We are continuing to generate resolution reports for anyone who has yet to receive them this month.
Posted Jul 23, 2025 - 20:20 UTC

Monitoring

Jon on our technical team has deployed a fix and this month's run of the resolution report has resumed. It may take a several days before all reports have been distributed to our members. -IF
Posted Jul 22, 2025 - 21:37 UTC

Update

We are continuing to investigate this issue.
Posted Jul 22, 2025 - 19:40 UTC

Investigating

We distributed about a third of this month's resolution report before the batch run failed. Our technical team is working on a fix. Once the fix is in place, we will distribute the remaining resolution reports for this month. -IF
Posted Jul 22, 2025 - 17:45 UTC