Reference visibility in the REST API has reverted - all references should be set to open
Incident Report for Crossref
Resolved
We've confirmed that the changes we have made so that all references registered with us are treated as open metadata are accurately reflected in the REST API again, so we're closing this incident.
Posted Jun 30, 2022 - 07:36 UTC
Monitoring
A fix has been implemented. We're going to leave this incident open until tomorrow so we can continue to monitor, and then confirm that the changes we have made so that all references registered with us are treated as open metadata are accurately reflected in the REST API.
Posted Jun 29, 2022 - 17:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 29, 2022 - 17:25 UTC
Investigating
We recently announced that all references registered with us would be treated as open metadata (https://www.crossref.org/blog/amendments-to-membership-terms-to-open-reference-distribution-and-include-uk-jurisdiction/). It appears that change has been reverted in our REST API, and, thus, not all of references are being treated as open metadata. We're currently investigating.
Posted Jun 29, 2022 - 17:08 UTC
This incident affected: APIs (Public REST API, Polite REST API) and Metadata Plus (Plus REST API).