Admin tool - doi.crossref.org - returning a 503 status code

Incident Report for Crossref

Resolved

This incident has been resolved. Our admin tool was down for approximately 140 minutes. We are now accepting and processing all submissions. -IF
Posted Aug 09, 2026 - 22:34 UTC

Update

This incident is also resulting in errors for our members using the web deposit form and Metadata Manager. -IF
Posted Aug 09, 2026 - 22:18 UTC

Investigating

We are currently investigating this issue.
Posted Aug 09, 2026 - 21:46 UTC
This incident affected: Content Registration (Admin tool, Web deposit form, New Metadata Manager).