This incident has now been resolved by Turnitin. - KL
Posted Dec 11, 2025 - 17:25 UTC
Investigating
Turnitin has reported that users in Europe may have issues logging into their iThenticate accounts. They are currently investigating the issue. Please see their status for updates: https://turnitin.statuspage.io/incidents/krzh571rxsc2
Posted Dec 11, 2025 - 16:41 UTC
This incident affected: Integrations and external dependencies (Monitoring of iThenticate can be seen at https://turnitin.statuspage.io.).