Members reporting errors when attempting to update records using our new record registration form

Incident Report for Crossref

Identified

The issue has been identified. This bug is only affecting DOIs with more than one /. Those DOIs will continue to trigger the ‘Error Loading Metadata’ failure messages until we fix the issue. -IF
Posted Dec 16, 2025 - 20:55 UTC

Investigating

We have had members reporting ‘Error Loading Metadata’ failure messages in our new record registration form -https://manage.crossref.org/records - when updating existing records. Our technical team is investigating. -IF
Posted Dec 16, 2025 - 19:17 UTC
This incident affects: Content Registration (Record registration form).