Possible problem with Crossref content submission - now solved
Incident Report for Crossref
Resolved
The missing submissions have all been processed, so we're closing this issue.
Posted Nov 25, 2022 - 10:54 UTC
Update
We will continue to monitor this until tomorrow, but the backlog of files seem to be moving well through the queue and we expect them all to have been processed today. Thanks for your patience if you've been waiting for one of your submissions!
Posted Nov 24, 2022 - 16:24 UTC
Monitoring
We believe we have identified the problem and have a fix in place.

Some registrations were moving through the queue normally, but some were not reaching the queue, and this seems to have been caused by an unreliable internal service. We’ll be working on the service in future to avoid this happening again.

In the meantime, all missing submissions are now moving through the queue, and should be processed over the course of the day. We will continue to monitor the server during this time.
Posted Nov 24, 2022 - 12:40 UTC
Investigating
We’ve received reports of content submissions not appearing in the submission queue and no emails being received to confirm that registration has completed. The team is investigating the problem, and we'll be back in contact when we know more.
Posted Nov 24, 2022 - 09:01 UTC
This incident affected: Content Registration (Admin tool).