Undelivered email notifications from the test admin tool (test.crossref.org)
Incident Report for Crossref
Resolved
This incident has been resolved. Email notifications from the test admin tool are now being delivered.
Posted Jun 08, 2020 - 14:31 UTC
Identified
Due to a high rate of bounced emails in our test admin tool (test.crossref.org), we have not been able to reliably deliver all submission messages from that tool over the past week. We have temporarily suspended the sending of notification emails from the test admin tool and will review the situation early next week. The production system (doi.crossref.org) is not affected.
Posted Jun 05, 2020 - 16:53 UTC
This incident affected: Content Registration (Test admin tool).