Content registration degraded for maintenance
Incident Report for Crossref
Resolved
The database maintenance is complete. Files are processing normally.
Posted Apr 08, 2023 - 17:19 UTC
Investigating
We are planning to do emergency maintenance over the next 2 hours. The submission queue may be paused in this time. We will update if this happens.
Posted Apr 08, 2023 - 16:16 UTC
This incident affected: Content Registration (Admin tool).