Crossref Search is down

Incident Report for Crossref

Resolved

We have increased capacity, and the service is now restored. Thanks for your patience!
-GH
Posted Jun 03, 2025 - 12:15 UTC

Investigating

For the last hour, Crossref Search has been showing a 504 timeout status response due to heavy use. We're investigating and looking at adding more capacity to balance the high traffic.
-GH
Posted Jun 03, 2025 - 10:12 UTC
This incident affected: Sites (Metadata search).