Problems logging into web deposit form
Incident Report for Crossref
Resolved
This problem has been resolved. We recently updated our security certificates and the web deposit form needed updating to recognise the new security certificates. Members should now be able to login to the web deposit form as usual. Thanks for your patience!
Posted Jun 18, 2024 - 11:08 UTC
Identified
We think we have identified the cause of this problem, and our developers are working on a solution now.
Posted Jun 18, 2024 - 10:04 UTC
Investigating
We have had a few members report problems logging into the web deposit form with their usual credentials. Our team is investigating and we’ll update when we know more. EA
Posted Jun 18, 2024 - 07:54 UTC