503 errors with the test admin tool (test.crossref.org)
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 22:15 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2020 - 18:11 UTC
This incident affected: Content Registration (Test admin tool).