Problem with Crossref content submission - recurring incident
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Dec 19, 2022 - 14:09 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 14, 2022 - 15:18 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 12, 2022 - 19:32 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 09, 2022 - 21:34 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 08, 2022 - 18:58 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 07, 2022 - 17:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 06, 2022 - 22:09 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 05, 2022 - 16:26 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 02, 2022 - 21:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Dec 01, 2022 - 21:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2022 - 15:03 UTC
Update
The unplanned release to fix the underlying cause of this problem has been completed. We're now processing your submissions. And, we're monitoring the overall results of this fix.
Posted Dec 01, 2022 - 15:03 UTC
Identified
We are currently deploying a fix for the underlying problem. During this deployment, members may experience delays in deposit system admin tool (doi.crossref.org) processing. Deposits submitted during this time will be stored and processed after the maintenance has been completed.
Posted Dec 01, 2022 - 14:20 UTC
Update
This issue was still ongoing and a restart of a service was needed to push through files which were yet to reach the queue. Our technical team are still working on a permanent fix but hope the service restart will push through files waiting to be processed until the fix is implemented.
Posted Dec 01, 2022 - 12:18 UTC
Monitoring
Like last week, we have observed that some registrations were moving through the submission queue normally, but others were not reaching the queue (we were still accepting and storing those submissions). This seems to have been caused by an unreliable internal service. We've identified the problem, implemented a fix and all submissions are now processing, and will continue to monitor the incident. Our technical team is working on the service to avoid this from happening again in the future.
Posted Nov 30, 2022 - 16:36 UTC
This incident affected: Content Registration (Admin tool) and APIs (Polite REST API, Crossmark dialog server).