Submission log email notifications for registrations to our admin tool - doi.crossref.org - currently delayed

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Oct 13, 2023 - 13:08 UTC

Update

We are still working through the backlog of submission notifications. Notification emails are delayed, but we are sending them. So, if you are expecting a submission notification via email with the submission log details of your registrations, it will be delivered.

In the interim, you can confirm any past registrations in our admin tool using these instructions: https://www.crossref.org/documentation/register-maintain-records/verify-your-registration/submission-queue-and-log/#00143
Posted Oct 12, 2023 - 15:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 11, 2023 - 19:54 UTC

Investigating

We have had several members report that they are not receiving submission logs via email for their registrations starting around 1000 UTC today. We have been able to replicate the issue and are investigating it further. In the interim, we are still processing those submissions and you can confirm any past registrations in our admin tool using these instructions: https://www.crossref.org/documentation/register-maintain-records/verify-your-registration/submission-queue-and-log/#00143
Posted Oct 11, 2023 - 18:39 UTC
This incident affected: Content Registration (Admin tool, Test admin tool).