Web deposit form: degraded performance

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Mar 10, 2023 - 14:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2023 - 18:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 09, 2023 - 14:50 UTC

Update

We are continuing to investigate this issue.
Posted Mar 08, 2023 - 18:03 UTC

Investigating

We're observing problems with our web deposit form - https://apps.crossref.org/webDeposit/ - at the moment. Loading times are slow and some users are reporting problems accessing the web deposit form. We're investigating.
Posted Mar 08, 2023 - 15:38 UTC
This incident affected: Content Registration (Admin tool).