our main website is currently unavailable
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 15:20 UTC
Monitoring
We have brought the website back and identified the issue. It was down for 30 mins. Monitoring now.
-GH
Posted Dec 05, 2023 - 22:11 UTC
Investigating
Our main website at www.crossref.org has been unavailable since 21:35 UTC. We're looking to get it back ASAP; please bear with us!
-GH
Posted Dec 05, 2023 - 21:56 UTC
This incident affected: Sites (Crossref website).