We have identified and fixed the issue affecting user logins. This incident is now resolved.
Posted Jul 14, 2026 - 09:16 UTC
Investigating
Some users are currently experiencing login issues with the Admin Tool, New Metadata Manager, and Web Deposit Form. We are currently investigating the issue.
Posted Jul 14, 2026 - 08:36 UTC
This incident affected: Content Registration (Admin tool, Web deposit form, New Metadata Manager).