Similarity Report Generation Issues
Incident Report for Crossref
Resolved
Turnitin has resolved this issue.
Posted Jul 22, 2021 - 18:36 UTC
Identified
Turnitin is working on a fix for Similarity Reports that are not currently generating. You can follow the status of their updates here: https://turnitin.statuspage.io/
Posted Jul 22, 2021 - 17:29 UTC
This incident affected: External dependencies (Similarity Check via iThenticate from Turnitin - status found at https://turnitin.statuspage.io/).