Main website is down

Incident Report for Crossref

Resolved

Our team has confirmed that this issue was caused by a problem with our load balancer. We’ll be looking further into how this happened.
Posted Nov 21, 2023 - 10:02 UTC

Monitoring

Our main website is now back up and we are investigating to see what caused the problem.
Posted Nov 21, 2023 - 09:05 UTC

Investigating

Our main website has been down since last night (20th Nov) and we are investigating urgently.
-GH
Posted Nov 21, 2023 - 08:11 UTC
This incident affected: Sites (Crossref website).