Metadata Search outage for 24 hours
Incident Report for Crossref
Resolved
We found the issue which was related to an instability with DNS. We applied a fix yesterday and the service is stable. Resolving this issue. Thanks for your patience!

-GH
Posted Mar 12, 2024 - 17:37 UTC
Monitoring
Metadata Search (search.crossref.org) suffered a complete outage from about 10.15 AM UTC on Sunday 10 March until 10.30 AM UTC on Monday 11 March. We have deployed a fix for this issue and are continuing to monitor the situation.
Posted Mar 11, 2024 - 11:13 UTC
This incident affected: Sites (Metadata search).