Submission processing delays today
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted May 28, 2024 - 17:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 28, 2024 - 17:32 UTC
Investigating
Submission processing in our admin tool - doi.crossref.org - has been delayed for the last hour or so. We're aware of the problem and actively working on a fix. Deposits submitted during this time will be stored and processed once we have the situation resolved. -IF
Posted May 28, 2024 - 17:16 UTC
This incident affected: Content Registration (Admin tool).