Problems with search.crossref.org
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Feb 26, 2024 - 21:57 UTC
Monitoring
search.crossref.org seems to be stable again. We think this problem was caused by heavy traffic to our APIs, so we have added extra resources and will continue to monitor.
Posted Feb 26, 2024 - 10:55 UTC
Investigating
search.crossref.org is not currently working well - our team is investigating and we'll post more as we learn more.
Posted Feb 26, 2024 - 09:10 UTC
This incident affected: Sites (Metadata search).