Test admin tool - test.crossref.org - is down

Incident Report for Crossref

Resolved

This incident has been resolved.
Posted Sep 27, 2026 - 01:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2026 - 01:38 UTC

Investigating

Our test admin tool is down at the moment. Members are receiving a 503 service unavailable message when trying to access test.crossref.org. -IF
Posted Sep 27, 2026 - 01:22 UTC
This incident affected: Content Registration (Test admin tool).