Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 14:00 UTC
Scheduled
We will be undergoing special scheduled maintenance - release version 0.231.0 - on 27 March from 1400 to 1600 UTC to roll back issues related to submission processing lags. Our members may experience delays in deposit system admin tool (doi.crossref.org) processing. Deposits submitted during this time will be stored and processed after the maintenance has been completed.
Posted Mar 26, 2025 - 19:05 UTC
This scheduled maintenance affected: Content Registration (Admin tool, Test admin tool, Web deposit form, Record registration form) and Beta (Metadata Manager).