Investigating an outage

Incident Report for Crossref

Resolved

Participation Reports, the web deposit form, and other small apps and reports have been fully operational again since about 08.30am UTC.
Posted Jun 16, 2026 - 11:59 UTC

Monitoring

A fix has been implemented. The services are available again and working as expected. We are now monitoring their performance and continuing to investigate the cause of the incident.
Posted Jun 16, 2026 - 08:41 UTC

Investigating

We are investigating an incident with multiple tools and services including:
- Web deposit form (https://apps.crossref.org/webDeposit)
- Participation Reports (https://crossref.org/members/prep/)
- Browsable title list (https://www.crossref.org/titleList/)
- Other reports and forms under crossref.org

Starting from around 04.16am UTC on 16 June, users attempting to access these tools have been receiving 503 errors.

Our technical team are investigating. We'll provide updates as soon as we know more.
Posted Jun 16, 2026 - 08:15 UTC
This incident affected: Sites (Participation reports) and Content Registration (Web deposit form).