Network Maintenance

Incident Report for Crossref

Resolved

The network maintenance is complete.
Posted Oct 08, 2023 - 00:57 UTC

Identified

The Crossref network will be upgraded on Saturday, Oct. 7, 2023. While we do not anticipate any outages, there is always the possibility one may occur.
Posted Oct 06, 2023 - 15:32 UTC