Submission processing delays
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Jun 20, 2024 - 21:24 UTC
Monitoring
Submission processing has been delayed in our admin tool - doi.crossref.org - over the last 24 hours. We are monitoring the situation. Performance of the system is currently degraded. We're storing all submissions and processing those submissions as quickly as we can. -IF
Posted Jun 14, 2024 - 07:48 UTC
This incident affected: Content Registration (Admin tool).